Author Topic: Everything is now Secure (or what just happened to the forum?)  (Read 1981 times)

Ed Lecuyer

  • Administrator
  • Superintendent
  • *****
  • Posts: 3,592
    • View Profile
    • wwfry.org
In order to increase our ranking with Google, and to make our web site not appear to be malicious in certain web browsers and computing environments, our main web site, along with the online discussion forum, is now "Secure" with a valid "SSL Certificate." What this means is that you should now see a lock (or similar designation) at the top of the browser window whenever visiting any portion of the WW&F web site.

Previously, only the giftshop.wwfry.org and the ticketing platform were secure. Now everything is secured, and we should see the benefits in increased confidence for visitors to purchase tickets & merchandise, and inquire about our railway.

While I was at it, the main web page got a number of internal (and a few external) updates.

For a short while, while this was all going on, both the main web site and the forum did not work correctly. I was promptly notified by THREE members of the issue, which should now be resolved. I did note that I needed to reset at least one bookmark for a forum page I access frequently. However, everything appears to work when launched from https://forum.wwfry.org and https://www.wwfry.org.

Let me know if you are having difficulty, or find any inaccessible links lurking on our web site.
Ed Lecuyer
Moderator, WW&F Forum

Mike Fox

  • Museum Member
  • Empire Builder
  • ********
  • Posts: 5,138
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #1 on: March 08, 2021, 10:47:21 PM »
Excellent work as always Ed. I have been using the Forum for research for an article and when it hit my research was over. Thanks for being on top of it.

Mike
« Last Edit: March 08, 2021, 11:37:22 PM by Ed Lecuyer »
Mike
Doing way too much to list...

Benjamin Richards

  • Museum Member
  • Brakeman
  • ***
  • Posts: 188
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #2 on: March 09, 2021, 10:02:12 AM »
All the links I've tried, including those that hard-set http:// as well as those with no protocol specified at all, successfully redirect to https.

Ed Lecuyer

  • Administrator
  • Superintendent
  • *****
  • Posts: 3,592
    • View Profile
    • wwfry.org
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #3 on: March 09, 2021, 03:45:36 PM »
HELP NEEDED!!

I'm seeing some poor display of the main web page https://www.wwfry.org on certain Apple devices.

If you have a Mac, iPhone, or iPad, please check the https://www.wwfry.org web page and let me know:
1. It looks great.
or
2. It looks terrible. I have a <device type> and using <browser, usually "Safari"> as my web browser.

Please post responses here; do not email/text them to me as that makes it more difficult to keep track of what is doing what.

THANKS!!
« Last Edit: March 09, 2021, 05:01:20 PM by Ed Lecuyer »
Ed Lecuyer
Moderator, WW&F Forum

Bill Reidy

  • Museum Member
  • Dispatcher
  • *****
  • Posts: 1,145
  • Life member. Ack.
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #4 on: March 09, 2021, 04:17:17 PM »
Hi Ed.

Checking my iPhone, sorry to say I have to go with choice 2:

It looks terrible. The text is all scrunched along the left side of the page. 

I have an iPhone and am using "Safari" as my web browser.
What–me worry?

Keith Taylor

  • Museum Member
  • Engineer
  • ****
  • Posts: 707
  • Life Member
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #5 on: March 09, 2021, 04:21:23 PM »
Ed, on my ipad the site looks fine. However some pages show the padlock at the top and some....like the one I am looking as I write this it doesn’t appear.

Keith

Wayne Laepple

  • Museum Member
  • Yardmaster
  • *******
  • Posts: 2,000
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #6 on: March 09, 2021, 04:46:28 PM »
Everything looks good on my desktop iMac. It's a different story on my iPad, however. There is this horrific blue background with the lettering all in black and crammed over to the left side of the screen. No sign of a padlock anywhere, either. On the iPad, the Forum comes up with no padlock, but at least it comes up. On the iMac, not so much. It used to pop right up as a favorite, but now that feature takes me to the WW&F home page and I have to access the Forum from there.

Forgot to mention I see no difference between Safari and Chrome.

Hope that helps, Ed.
« Last Edit: March 09, 2021, 05:24:46 PM by Wayne Laepple »

Philip Marshall

  • Museum Member
  • Engineer
  • ****
  • Posts: 673
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #7 on: March 09, 2021, 04:50:55 PM »
It looks fine on my MacBook Pro laptop using either Firefox or Safari (I tried both).

Keith Taylor

  • Museum Member
  • Engineer
  • ****
  • Posts: 707
  • Life Member
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #8 on: March 09, 2021, 05:31:57 PM »
Yikes!
While the forum appears well on my ipad.....the main WW&F web page is horrendous.

And again.....no evidence of a pad lock up top.

Keith

Bob Holmes

  • Museum Member
  • Engineer
  • ****
  • Posts: 682
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #9 on: March 09, 2021, 08:53:25 PM »
Great job Ed (!) to make the site totally secure (which I have always been nervous about).  I'm hoping the feedback you're getting will help you finish the job to everyone's satisfaction.

Bob

Dave Buczkowski

  • Museum Member
  • Conductor
  • *****
  • Posts: 900
  • Life Member
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #10 on: March 09, 2021, 09:31:58 PM »
Ed,
On my iPad the first link is the blue background with black print and no photos. The lettering is fine. It works fine on the second link.
Dave

Hunt Dowse

  • Museum Member
  • Flagman
  • *
  • Posts: 35
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #11 on: March 09, 2021, 11:05:53 PM »
Ed,
Same results as Bill and Dave on my iPad.  Text but no graphics on the home page.
Hunt

John Scott

  • Museum Member
  • Baggageman
  • **
  • Posts: 136
  • Life Member
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #12 on: March 10, 2021, 04:44:33 AM »
Hopeless, as described above, on all my quite new Apple devices (desktop, phone and MacBook Pro) but just lovely on my old series II iPad which is running iOS 9.3.6 and which cannot be updated. It must be an Apple incompatibility issue.

Mike the Choochoo Nix

  • Museum Member
  • Hostler
  • ***
  • Posts: 285
    • View Profile
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #13 on: March 10, 2021, 09:58:14 AM »
It also looks fine on my old unupdateable I-pad.
M.Nix
Mike Nix

Ed Lecuyer

  • Administrator
  • Superintendent
  • *****
  • Posts: 3,592
    • View Profile
    • wwfry.org
Re: Everything is now Secure (or what just happened to the forum?)
« Reply #14 on: March 10, 2021, 11:03:04 AM »
So everything is inconsistent - which is PERFECT for computers that always do exactly and only what they are told to do.

My thought is that this is some sort of propagation issue with the DNS servers preferred by certain Apple devices. This is resulting in mixed content from HTTP (not secure) and HTTPS (secure) servers. The most obvious piece of missing/misdirected content being the style sheet that controls the page layout.

I expect that this will sort itself out over the next 24 hours. In the meanwhile, I made the background color of the page white (rather than blue) so that the text is legible for the time being.
Ed Lecuyer
Moderator, WW&F Forum